CDN issues with MaxCDN (one of our CDN providers)

Incident Report for LiftIgniter

Resolved

This incident has been resolved.
Posted Oct 21, 2021 - 14:35 UTC

Investigating

For a little under an hour, from 2021-10-20 8:04 UTC to about 2021-10-20 8:46 UTC, MaxCDN, one of the CDN providers that we use to serve traffic, was slow and unresponsive for part of our Australia traffic due to scheduled maintenance in the Sydney region: https://status.maxcdn.com/incidents/0stcf5zpm766.

Customers with significant web traffic volume in Australia were affected. Customers using a version of the LiftIgniter snippet that automatically tries against the Cloudfront CDN when MaxCDN is down woud be partly insulated. Even so, since there is some time lag for the retry, we did fail to capture data for their end users who bounced before the retry could be triggered, and failed to show recommendations for users who scrolled to recommendation areas before the retry had kicked in.

API integrations were not affected, so apps were unaffected.

We are working with MaxCDN's parent company, Stackpath, to transition from MaxCDN's infrastructure to Stackpath's infrastructure, which we expect to be more robust to scheduled maintenance. We expect such incidents to stop happening once we transition.
Posted Oct 21, 2021 - 14:34 UTC